Joinpoint Revision History

What are the most recent changes to the Joinpoint program?

Version 4.8.0.1 (released April 22, 2020) 

Bug Fixes

  • Data files with very small standard errors caused the Permutation Test to miscalculate the P-Values and potentially affected the Final Selected Model. This miscalculation is only present in version 4.8.0.0. It is recommended users re-run any analyses conducted with Joinpoint 4.8.0.0 that used the Permutation Test.

     

      

Version 4.8.0.0 (released April 15, 2020) 

New Features

  • Minimum APC Difference Worth Detecting (MADWD) - In some situations Joinpoint may determine that there are one or more pairs of segments where the difference in the Annual Percent Change (APC) between some consecutive segments is quite small. Users can enter a minimum APC difference worth detecting as a minimum percentage point difference (Min. PPD). Joinpoint will start with the final selected model that was chosen using the specified analysis criteria and lower the number of Joinpoints until all consecutive segments pass the Min. PPD criteria.
  • Copy Graph – The Joinpoint graph can now be copied to the user’s clipboard from the right click menu.
  • Cohort Tree Filter – Certain filter options can now be set as default options for each new Joinpoint Output.

Bug Fixes

  • By-variables with equal signs in their text would not display properly in the Joinpoint Output.
  • By-variables with leading or trailing spaces in their values prevented sessions from executing.
  • Sessions with the Pairwise Comparison option that had varying number of observations were allowed to execute when they should not.
  • The Control Box was added to the Nag warning for Default System Font allowing users to close the warning when the “Ok” button is not visible.
  • The Output Properties was displaying the Jump Location for the Comparability Ratio.
  • Removal of duplicate Independent Variable values in the Define Variable Window
  • If a session had missing Dependent Variable values and the Type of Variable was set to “Count”, Joinpoint would throw an exception.
  • Joinpoint would crash if a session had varying number of observations and too few observations to fit any Joinpoints.
  • Quotes around the Adjustment Variable in the data file caused an exception.

     

      

Version 4.7.0.0 (released February 26, 2019)

New Features

  • Two new model selection methods were added: Weighted BIC and Weighted BIC-Alternative.
  • The statistically significant flag was changed from ^ to *.
  • The restriction requiring Standard Populations to be the same across cohorts when calculating age-adjusted rates was removed.
  • When using a data file that has 32 or more observations, a message is displayed to users to recommend setting the maximum number of Joinpoints to 6.
  • A “Session Note” field was created.  This allows users to add a brief note on the Joinpoint session that is then displayed in the output.
  • A new export file was created that contains the number of Joinpoints in the Final Selected Model for each cohort.
  • A second Execute button was added that prevents Joinpoint from displaying any warning messages before running the session.
  • A custom display labels option was added to the independent variable define.

Bug Fixes

  • Toggling the "File contains column headers" option could result in a double header being displayed in the data preview window.
  • SEER*Stat export with variables as "Quoted Labels" caused Joinpoint to crash.
  • The Include/Exclude cohorts feature did not exclude Delay & Non-Delay cohorts correctly.
  • Opened JPO now displays the file name in the header.
  • Double clicking a JPS file whose data file had changed caused that file to open multiple times.
  • Fixed the Nag Warning display for zoomed displays.
  • Added correct .dll files required to use the "Print" feature.
  • Fixed a bug when Joinpoint encountered blank lines in the data file.
  • Fixed a bug involving missing character=space and data files containing missing data.
  • Updated the help links to the correct base page on the Plone site.
  • Update the Parameters report to correctly reflect the current UI.

 

Version 4.6.0.0 (released April 16, 2018)

New Features

  • Added “Data Dependent Selection” as a new Model Selection Method option. This is an Alpha feature.
  • Added “BIC3” as a new Model Selection Method option.
  • Added the ability to select Parametric or Empirical Quantile methods for APC and Tau Confidence Intervals.
  • Two separate methods of the Empirical Quantile confidence interval calculations are now provided:  Method 1 and Method 2.  This is an Alpha feature.
  • Added the option to set the seed value used for generating random numbers during resampling under the Empirical Quantile method as well as an option to keep the see constant or have it change with each cohort.
  • A new Joinpoint File Type was created. The Joinpoint Template (.jpt) allows users to save their Session settings, including variable locations, and then create a new session with a new data file. This allows users with multiple similar data files to easily recreate sessions.
  • Added a more advanced filter control to the Cohort Tree of the Output Window.
  • Added slope significance indicator on the Output Window graph when Log Transformation is No.
  • Added a new grid to the Model Selection tab of the Output Window which displays the Model Selection Method chosen.
  • Added a footer to the Output Window to display the Confidence Interval Method used.
  • Added examples on how to call the console version from a SAS or R program.
  • Right-click “Save As” for graphs now supports PNG and TIFF formats (for normal and high resolution graphs).

Bug Fixes

  • Changed the data file preview grid (on the Input Tab of the Joinpoint session) to allow keyboard navigation.
  • Removed Multi-Group Clustering group box from the Advanced Analysis Tools Tab of the Joinpoint session.
  • Improved the loading and processing of input data files.
  • Improved the display of formulas in the online help.
  • Fixed the High Resolution Graph to look more like the normal graph.
 

 

Version 4.5.0.1 (released June 12, 2017)

New Features

  • The value 100 has been added to the list of possible “Rates per” (population at risk) when computing Crude or Age-Adjusted Rates.

Bug Fixes

  • As of version 4.5.0.0, users can set the Alpha levels for the Joinpoint Locations, APCs, AAPCs, and Jump Value and Comparability Ratio.  Upon installation of that version, the default values for each were set incorrectly to 0.5.   The default values should have been 0.05.   Installing the new version of Joinpoint (4.5.0.1) will change any 0.5 Alpha setting to 0.05.
  • The significance level footnote on the Model Selection tab referenced the wrong alpha level.  This has been corrected.

 

 

Version 4.5.0.0 (released May 17, 2017)

New Features

  • Two tabs on the Session Window have been renamed. “Advanced” has become “Method and Parameters”. “Comparison” is now “Advanced Analysis Tools”. Several controls on these tabs have been moved. More details are below.
  • The Grid Search now has specific parameters for controlling Joinpoint placement. The default values for Grid Search’s “Minimum number of observations from a joinpoint to either end of the data” and “Minimum number of observations between two joinpoints” have been changed. For more details on this change, please go to the Help section.
  • Hudson’s Method has been disabled.
  • The Pairwise Comparison has two new parameters: Significance Level and Max Number of Randomly Permuted Data Sets.
  • Alpha Values for APCs, AAPCs, and Jump Value and Comparability Ratio have been added to the Session Preferences. Session Preferences can now be defaulted to different values.
  • For Jump Model and Comparability Ratio Model analyses, the “CR Estimate” is now displayed in the Graph Legend on the Output Window. Added CR Estimate precision setting to the Display Options window.
  • An APC/Slope precision setting has been added to the Display Options window.
  • Jump Model and Comparability Ratio display and precision options have been added to the Display Options window.
  • The layout of the Model Selection and Comparison tab settings in the Display Options window has been updated.
  • Added the Alpha Level to the footer of the Model Selection tab on the Output Window.

Bug Fixes

  • If the Jump Model option was run, the Comparability Ratio table (located on the Model Estimates output tab) contained an incorrect statistic. For the Jump Model, the column labeled “Variance of CR (a/b)” contained the standard error of the comparability ratio value produced from the Jump Model, not the variance. The variance column has been replaced by a column containing the standard error of the comparability ratio.
  • The Comparability Ratio table, located on the Model Estimates tab when the Jump Model or Comparability Ratio Model are run, has been corrected with the following additional adjustments:
    • The Comparability Ratio Model now produces a Lower and Upper CI, Test Statistic and p-value. These are computed using a normal (z) distribution.
    • Several footnotes have been added to the table to better describe the statistics displayed.
  • If all values of a by-variable weren’t present in the first grouping for the by-variable, Joinpoint wouldn’t execute due to encountering an unknown value for the by-variable.
  • The fields for the Comparability Ratio model export were in the wrong position.
  • 0.5 is added to zero counts only under the following conditions:
    • The Run Type is “Provided in Data File”, the Type of Variable is “Count”, and the Heteroscedastic Errors Option is “Poisson Variance”.
    • The Run Type is “Provided in Data File”, the Type of Variable is “Count”, the Heteroscedastic Errors Option is “Constant Variance”, and the Log Transformation is “YES”.
    • The Run Type is “Calculated from Data File”, the Type of Variable is “Crude Rate”, and the Heteroscedastic Errors Option is “Poisson Variance”.
    • The Run Type is “Calculated from Data File”, the Type of Variable is “Crude Rate”, the Heteroscedastic Errors Option is “Constant Variance”, and the Log Transformation is “YES”.
  • A message is displayed in the Output Window for each cohort that had 0.5 added to one or more zero counts.
  • A warning message is now displayed when the number of permutations for the Permutation Test is set below 4499. The minimum number of permutations allowed is now 1000.
  • Fixed a problem where APC and AAPC exports were adding an extra field delimiter at the end of each row.
  • Corrected the display of the Dependent Value column headers on the Data Tab of the Output Window.
  • Added restriction that you can only use Poisson Variance if using Provided Count or Calculating Crude Rate.
  • The Maximum number of joinpoints was not being validated on the correct Grid Search settings.
  • Fixed a problem where grids on the Output Window were not always left aligned.
  • Fixed a crash in the Output Window when the Non-Delay cohort of a Delay \ Non-Delay session was a bad cohort.
  • The Comparability Ratio grid on the Output Window will display an explanation footer when an incomputable value is displayed.
  • For Jump and Comparability Ratio runs:
    • The Last Observation of Old Coding must be at least 4 or more data points from either end of the data.
    • If you use Constant Variance, the Variance of Comparability Ratio will be set to N/A.
    • You cannot set Log Transformation to No.

 

 

Version 4.4.0.0 (released January 4, 2017)

New Features:

  • Session Options:
    • Jump Model and Comparability Ratio calculation options have been added, which allows analysts to estimate trends even when there is a coding change in the data series. For further information on these new options please refer to the help manual.
    • The ability to analyze only select cohorts from the input data.
    • Joinpoint can now analyze data files containing cohorts with an unequal number of observations.
  • Output Viewer Options:
    • The output viewer window now contains a tree view for selecting cohorts.
    • Multiple cohort models can be viewed on a single graph. All other output tab information is also updated to contain all of the selected cohort models.
    • AAPC ranges can be specified using the output menu.
  • Joinpoint can now export high resolution graphs.
  • By Variables now allow text values.
  • Joinpoint now has an on-line tech support request form.

 Bug Fixes:

  • Logarithmic scale display on the Output Window graph sometimes displayed incorrect Y axis values.
  • In rare occurrences, the graph axis positions in the Output Window did not show all observed data values.
  • JPO files over 1 megabyte would sometimes cause loading errors.
  • Dictionaries with a variable format of “labels” would show as blank in the Format Editor.
  • Some session properties were not being displayed in the Output Properties window.
  • Joinpoint will not let users add or remove variables when a SEER*Stat Dictionary file is used.

 

 

Version 4.3.1.0 (released April 19, 2016)

Bug Fixes:

  • Several library files were missing from the 4.3.0.0 installation. Those library files prohibited some users from reading or exporting to Excel and generating reports.
  • A bug in the By-Variable format generator was fixed.

 

 

Version 4.3.0.0 (released April 15, 2016)

New Features:

  • The Joinpoint session now has an input data tab. The new tab combines the Data Import Wizard and the session Specifications Tab.
  • AAPC ranges can now be set on the Advanced Tab.
  • Joinpoint now links to an on-line help system. If you do not have internet connectivity, a PDF version of the help system is installed with Joinpoint.
  • Matrix export was expanded to export to Excel.
  • Joinpoint now has 3 sample sessions. These sessions can be loaded from the menu File->Sample Joinpoint Sessions. These new sample sessions have replaced the “Blank Session” option.

 Bug Fixes:

  • Various bugs were fixed in the matrix export.

 

 

Version 4.2.0.2 (released June 23, 2015)

  • The data import wizard was updated to allow non-integer values.
  • When computing age-adjusted rates, Joinpoint will now skip cohorts when the total population for the cohort is zero.

 

 

Version 4.2.0.1 (released May 6, 2015)

  • The data import wizard was updated to correctly handle files containing the information needed for Joinpoint to compute age-adjusted rates.

 

 

Version 4.2.0.0 (released April 29, 2015)

New Features:

  • Joinpoint now provides a new method for computing AAPC Confidence Intervals. The new method is called the Empirical Quantile method. The previous AAPC CI method is still available and is called the Parametric method.
  • When performing the AAPC comparison and using the parametric method to calculate the AAPC Confidence Intervals, a new method has been implemented to calculate the confidence interval for the difference between the two true AAPCs. The AAPC comparison cannot be performed when using the Empirical Quantile method to calculate the AAPC Confidence Intervals.
  • Joinpoint can now process Delay and Non-Delay Adjusted statistics output by SEER*Stat. For SEER*Stat exports containing both delay and non-delay statistics, Joinpoint can graph both together for each cohort.
  • When computing crude or age-adjusted rates, Joinpoint now provides an option for users to display their rates per a certain population (e.g. 100,000 population at risk).

 Bug Fixes:

  • There was a problem with the handling of a specific data file via the import wizard that was identified and resolved.
  • A bug that prevented users from defining their independent variable values was resolved.

 

 

Version 4.1.1.5 (released February 26, 2015)

  • A bug preventing the use of CSV files was fixed

 

 

Version 4.1.1.4 (released February 19, 2015)

  • The p-value for a two-sided test that the true APC is zero is calculated based on a t distribution.

 

 

Version 4.1.1.3 (released December 29, 2014)

  • A bug was fixed involving the text file import wizard.

 

 

Version 4.1.1.2 (released December 15, 2014)

  • A small bug was fixed to prevent Joinpoint from terminating its calculations under certain circumstances.

 

 

Version 4.1.1.1 (released October 7, 2014)

  • A small bug was fixed to prevent Joinpoint from terminating its calculations under certain circumstances.

 

 

Version 4.1.1 (released August 5, 2014)

Bug fixes:

  • In pairwise comparison runs, all values in the AAPC comparison table were being flagged as statistically significant, whether or not that was actually the case. This problem has been resolved and the program now flags only those that are significant.
  • The X and Y axis labels in the output graphs were at times not being displayed. This problem has been resolved.

 

 

Version 4.1.0 (released April 25, 2014)

Enhancements:

  • Joinpoint now has the ability to process multiple cohorts simultaneously (threading). Joinpoint will inspect the PC it is running on and determine the number of cohorts that can be processed concurrently. Many times this is equal to the number of CPU cores on the PC. Processing multiple cohorts will decrease the time it takes Joinpoint to run a session. Please note that this feature will not work when executing Joinpoint under Windows XP. Windows XP users will only be able to process one cohort at a time (similar to previous versions of Joinpoint).
  • Users can adjust the maximum number of threads (cohorts to process concurrently) that Joinpoint will attempt to use when executing a session. Joinpoint will automatically set the number of threads to use to the maximum possible for the PC it is running on. Users can then lower the number of threads if they want. This option is provided via the File->Preferences menu.
  • A new session execution progress window has been created. The window will now show the progress of each cohort that it is currently processing. When multiple cohorts are being processed concurrently, a progress bar for each will appear in the progress window.
  • The APC and AAPC tables on the Trends tab in the output have two additional statistics: Test Statistics and P-Value.
  • The slope can now be displayed in the data table when the Log Transformation is set to NO. The report printing was also updated to reflect this change.

 Bug Fixes:

  • The AAPC Confidence intervals will only be computed if the variance of each associated APC is available.
  • The graphing of X-axis values where the range between the minimum and maximum value was less than one was updated to display 10 axis points.
  • The correlation and covariance tables on the Model Estimates tab in the Joinpoint output were computed only if unconstrained estimates with offending data points deleted is available.

 

 

Version 4.0.4 (released May 6, 2013)

  • The program was recompiled so that it would be compatible with Windows XP.

 

 

Version 4.0.3 (released April 29, 2013)

Enhancements:

  • If standard errors are used in the calculations, then they will be displayed on the Data tab (whether they are provided or computed). Users have the ability to change the display precision via the output options.
  • The APC footnote character was changed from * to ^.
  • The By Variable “Delete…” button was renamed to “Remove…”
  • When using a SEER*Stat dictionary file (*.DIC), any independent variable value with a dash (“-“) located in its format label will not be used in the analysis. The label will be updated to contain the following text: (not used in calculations). This functionality was added so that users would not have to reproduce their SEER*Stat analyses in order to remove totals or sub-totals in their independent variable.
  • Graph Display Option enhancements:
    • The legend can be moved to the Right, Left, Top, or Bottom of the graph.
    • X and Y axis label precision can be changed.
    • The locations of each Joinpoint can be displayed on the graph (e.g. “Joinpoint 1: 1981”)
    • The legend can be adjusted to display the APC ranges.
    • The modeled line for each cohort can be set to a single color (e.g. Blue). In comparison runs, the second cohort modeled line will be Green.
  • Added a Print button to the main Joinpoint toolbar.
  • File associations have been enabled for Joinpoint. Joinpoint will automatically open when either a Joinpoint session (*.JPS) or output matrix (*.JPO) file name is double-clicked.
  • Users can now drag and drop files onto the Joinpoint program and it is a file type Joinpoint recognizes it will open it up. Session (*.JPS) and Output (*.JPO) files will automatically open. If a .TXT file is dropped onto Joinpoint, this will trigger the Data Import Wizard. If a SEER*Stat DIC file is dropped, this will trigger the session open process.
  • In the output window, depending on which Model Selection Method was specified by the user, a tab with one of the following three labels was shown: “Permutation Tests”, “BIC”, or “Modified BIC”. Those three labels have been replaced by the following label: “Model Selection”. This modification was made to standardize the labeling in the Joinpoint application.
  • A standard way of labeling the best, selected model was implanted into the Joinpoint application. The label “Final Selected Model” will now appear instead of labels such as ‘Best Fit” and “Best Model”. This modification was made to standardize the labeling in the Joinpoint application.

Bug Fixes:

  • The Trends tab on the output form will not be displayed when the Log Transformation option is set to No. This is because no APCs or AAPCs are produced when this option is selected. Export and Output Options have also been similarly updated.
  • When having Joinpoint compute Crude Rates while using the Poisson Variance Heteroscedastic Errors Option, there was the potential to have Joinpoint read in the wrong data column for the counts. This has been resolved.
  • The covariance and correlation matrices for pairwise comparisons were not always refreshing themselves correctly when turning them on and off.

 

 

Version 4.0.1 (released January 9, 2013)

  • Fixed a bug dealing with the decimal symbol for international users.

 

 

Version 4.0 (released December 17, 2012)

  • Joinpoint can now calculate crude rates, age-adjusted rates, proportions, and percentages if their components are provided in the input data file. Associated standard errors can also be computed. Please see the Dependent Variable section for more details.
  • The following modifications were made to the Joinpoint Session:
    • The new Comparison tab was created. The tab contains the parameters related to Pairwise comparisons and Clustering. Clustering is a future enhancement.
    • The “Test for pairwise differences between by-groups” control (originally on the Specifications tab) was moved to the Comparison tab and renamed “Pairwise Comparison”. In order to produce Comparison analyses, users must also use the “Comparison Type” control on the Comparison tab.
    • The Specifications tab was reorganized. Some items have been moved to other parts of the screen and have more descriptive labels (i.e. “Model” was moved from the upper left to the lower right and is labeled “Log Transformation”).
    • The Dependent Variable section (on the Specifications tab) was expanded to accommodate Joinpoint’s new ability to compute various statistics (as previously mentioned). Users can now specify whether the Dependent variable will be calculated or provided and what specific type of variable it is (Count, Crude Rate, Age-Adjusted Rate, Proportion, Percentage, or Other).
    • The Heteroscedastic Errors Option was reorganized. The two Poisson options in the previous version of Joinpoint are now combined into one. “Poisson Variance using Crude Rate” is now specified by selecting Dependent Variable=Calculated, Type=Crude Rate, and Heteroscedastic Errors Option=Poisson Variance. “Poisson Variance using Count” is now specified by selecting Dependent Variable=Provided, Type=Count, and Heteroscedastic Errors Option=Poisson Variance.
  • A new report viewer has been implemented. Reports can be printed or exported to PDF, Word, or Excel.
  • The Autocorrelation Parameter is now displayed on the Model Estimates tab of the Output window when “Fit an automated errors model based on the data” is selected for the Autocorrelated Errors Options.
  • Errors found in the input data file are now reported by cohort. When a session is executed, if any data errors are found a special window is displayed with the errors found for each cohort.
  • Joinpoint is now compiled under Microsoft’s Visual Studio. The installation of Joinpoint includes Microsoft’s .NET framework 4.0.
  • All user-specific options are now saved in a parameter file instead of the Window’s registry.